This project is read-only.

Problem with ULS Log

Dec 26, 2013 at 8:34 AM
Thank you for all your dévellopement and explanation.
I followed your instructions but I am having trouble, can you help me?
  1. Install WSP using Powershell:
    Added "ULSLogViewer" in http://MySharePoint/_catalogs/solutions. The manual activation is not working.
In PowerShell command:
Add-SPSolution LiteralPath D: \wsp\ULSLogViewer.wsp
Install-SPSolution-Identity-ulslogviewer.wsp GACDeployment-AllWebApplications
get-identity-SPSolution ulslogviewer.wsp (Deployed = True)
  1. Activate Features in "Web Application Features":
    ULSLogViewer is not present in "Manage Site features"
    Enable-SPFeature-identity ULSLogViewer-Url http://MySharePoint (is already activated at scope)
  2. Create new Secure Store Application Traget, For more help go to: OK
ULSLogViewer is present in the "Settings" menu but it does not work (An unexpected error has occurred.)

Could not find any resources appropriate for the specified culture or the neutral culture.
Make sure "Resources.CID.Feature.resources" was correctly embedded or linked into assembly "App_GlobalResources.vpdh3qfh"
at compile time, or that all the satellite assemblies required are loadable and fully System.Resources.ManifestBasedResourceGroveler.HandleResourceStreamMissing(String fileName)
at System.Resources.ManifestBasedResourceGroveler.GrovelForResourceSet(CultureInfo culture, Dictionary`2 localResourceSets, Boolean tryParents, Boolean createIfNotExists...

Getting Error Message for Exception System.Web.HttpUnhandledException (0x80004005):
Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.Resources.MissingManifestResourceException:
Could not find any resources appropriate for the specified culture or the neutral culture.
Make sure "Resources.CID.Feature...

Thank you for helping me :)
Dec 27, 2013 at 8:42 AM
Edited Dec 27, 2013 at 8:42 AM
Hi, Thanks for download!

Please review the issue here: ISSUES PAGE

I thinks you try to open the solution from the Central Admin.. I wrote the solution for that on the ISSUES page.
Dec 30, 2013 at 8:05 AM
Hi, Thank you for your reply.

Can you tell me how to compile the sources for SharePoint 2013?
I tried with VisualStudio, WSPBuild, MakeCab, MsBuild but I do not.

Thank you for your help :)
Dec 30, 2013 at 8:48 AM
Open the project with VS2012..
Jan 3, 2014 at 11:02 AM
Hello orbiran,

After copy / paste files (CID.Feature.resx, CID.Feature.he-IL.resx)
Located in "ULSLogViewerFeature \ Source \ ULSLogViewer \ Resources"
In the "ULSLogViewerFeature \ Source \ ULSLogViewer \ App_GlobalResources"

I opened the project with VS2012, it does not fully load in sources and does not recognize the file ULSLogViewer.csproj.

I tried different method but none solves the problem.

Would you have a site that could explain me how to compile sources WSP?

Thank you for your help
Jan 3, 2014 at 12:57 PM
That's odd, can you give me print screen of the errors that you got from vs?
Jan 3, 2014 at 2:38 PM
thank you for your help

I posted the print screen on Hubic:

Link hubic
Jan 4, 2014 at 2:06 PM
Can you describe me what apps do you have on your dev server? you have SharePoint 2013 and VS2012 with all the sharepoint addins(VS) ?
Jan 6, 2014 at 2:42 PM
Please, tell me if it lacks a pre-requisites, I search for a while now and I tested several methods that did not work.

SharePoint server 2013
Visual studio 2012
-sharepoint client components
-windows identity foundation SDK 4.0
-Microsoft sharepoint developer tools for visual studio 2012
Jan 11, 2014 at 7:59 PM
Jan 17, 2014 at 11:28 AM
Thanks orbiran for your link.
I will follow directions and I'll let you know.